Known Issue: Agents over VPN are not receiving updates from server

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Article ID: 157823

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Updated On:

Products

Management Platform (Formerly known as Notification Server)

Issue/Introduction

The customer reported that the SMA agent itself doesn’t switch to use the VPN connection until the service is restarted. Clients that boot into a production Windows environment that then switch to a VPN connection, fail to get updates from the SMP.

Cause

To speed up connection, agent internally stores cache of IP addresses once the server name is resolved on the first connection attempt. When connection change occurs (such as VPN connection) agent doesn't clear its cache, and still tries to use old IP address, even though it may not be valid anymore.


 

Resolution

A permanent fix has been provided in 7.1 SP2 MP1 V5. (See HOWTO81832).

When connection changes (network adapters are added/removed) agent clears connection cache as well.

There is also an Symantec Management Agent pointfix available for customers that have installed ITMS 7.1 SP2 MP1 Rollup v4. See attached file called "Pointfix_eTrack2849031_7.1_SP2_MP1_v4_Agent.zip"

MINIMUM REQUIREMENT

 

SMP 7.1 SP2 MP1 with Rollup v4 installed (See HOWTO81832)

 

HOW TO INSTALL THIS POINTFIX


1.     Before  PF applying, make sure that NS is not accessible via Internet connection using the same FQDN as via LAN connection!

2.     Extract files from the archive to the NS hard drive.

3.     Make sure PointFix is extracted not to Altiris install directory (or any subfolder to it)!!!

4.     Execute PFInstaller.exe under user with administrative privileges.

5.    Accept UAC (User Account Control) prompt, select Install Files. Old SMA will be automatically backuped to the Backup folder at the same location where PFinstaller is and replaced with the new one. Log-file Log.txt will be created at the same location where PFinstaller is.

6.    Use Symantec Management Agent upgrade policy to update SMA agent. Clone or re-schedule Symantec Management Agent upgrade policy, if it was already used once.

 

CHANGES MADE

When connection changes (network adapters are added/removed) agent clears connection cache as well.

Agent version 7.1.15436.8436

 

 

This hotfix has the following known issues:

If NS is accessible from both LAN and Internet, with network configuration where Internet connection adds virtual network adapter (such as PPPoE connection), this may result in  all NS communication traffic to be redirected to Internet connection.


HOW TO UNINSTALL

1.  Make sure that Backup subfolder is located in PFinstaller’ directory

2. Execute PFInstaller.exe under user with administrative privileges.

3. Accept UAC (User Account Control) prompt, select Uninstall Files.

 


Applies To

ITMS 7.1 SP2 MP1

Attachments

Pointfix_eTrack2849031_7.1_SP2_MP1_v4_Agent.zip get_app