Symantec Protection Engine Java support matrix

book

Article ID: 157789

calendar_today

Updated On:

Products

Protection Engine for Cloud Services Protection Engine for NAS

Issue/Introduction

You would like to know what versions of Java are supported by Symantec Protection Engine for Network Attached Storage and Cloud Services.

Cause

​​Not Applicable

Resolution

Only Oracle JRE is supported. OpenJDK is not supported.

The following Java versions are expected to work with Symantec Protection Engine and are supported unless otherwise noted:

64-bit SPE (Supports only 64-bit Java)

SPE Version JRE 10* JRE 1.8 (up to 8u231) JRE 1.8 (8u232 to 8u251) JRE 1.8 (8u261+)**
8.2 Y N Y Y
8.1 Y Y Y N
8.0.x Y Y Y N
7.9.x Y (7.9.2 onwards) Y Y N

* Oracle Java JRE 10 reached End of Life in 2018 and is no longer supported. See Oracle Documentation for OS certification information with Java 10.
** See Additional Info Note 1 below.

32-bit SPE* (Supports only 32-bit Java)

SPE Version JRE 1.8 JRE 1.7
7.5.x W/L** Y(7.5.1 onwards) Y
7.5.x Solaris N Y
7.0.x W/L Y(7.0.3 onwards) Y
7.0.x Solaris N Y

* See Additional Information Note 2 below.
** W/L indicates Windows/Linux

Additional Information

Note 1: Starting with Java JRE 1.8.0_261 (8u261), Oracle moved to using the Microsoft Visual Studio 2017 tool chain to build releases. This move required changing the runtime library that JRE depends on (see the Oracle Java release notes for more information). Because of this change, SPE 8.1 and older are not expected to work with Java 8u261 and newer. They are not supported with Java 8u261 and newer.

Note 2: Not all versions of SPE listed here are still supported. Please see the end of service date matrix to determine if your version of SPE is still supported.

Note 3: For SPE 7.0.x, Java is required to run. For all newer versions, Java is only used for the local Administration Console and is not required for SPE to function. See our statement regarding SPE and Oracle Java for more information.