KNOWN ISSUE: HKCU Shell Folders doesn't show the correct information on the destination machine after migration

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Article ID: 157781

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Updated On:

Products

Deployment Solution

Issue/Introduction

We are able to capture the profiles with all the options for Windows Shell enable on the PCT template file on a Win XP or 7 machines after the migration on the destination machine the Shell folders are wrong.

Per example on the source machine if we check the registry shows the following for the user:
"HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\ShellFolders" we can see for Desktop on a Win 7 machine it says C:\Users\UserName\Desktop.

When we execute the package on a Win 7 machine if we check the "HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\ShellFolders" on the destination machine the information for Desktop is pointing to the wrong location per example: C:\Users\Administrator\Desktop.

And because of this issue we are having problems installing software.

If we disable in the template the option to capture Windows Shell options then the migration completes ok with the Shell Folders in the registry mapped to the correct user.

 

No error messages

Cause

 

When we capture the desktop settings and migrate it to new user created through  PCT, we modify the default desktop settings for this newly created user. When this  new user logs in for the first time windows will not treat this as first log in  and does not load the default settings for this new user. This is the reason that  the shell folders registry keys are not getting created for new user. This  behavior can be observed only when any desktop category item is checked for  migration.

 

Resolution

1- Please download the attached file (Shell_Folders_Issue_Siggned.7z) and extract the 2 files: PCTInst.exe and InstPCT.bin.

2- Once you have the files extracted go to the location of PCT folder and rename the existing PCTInst.exe and InstPCT.bin to extension .old.

3- Copy the new downloaded PCTInst.exe and InstPCT.bin to your PCT folder.

If you have questions or comments please contact Tech Support.

 

 

Applies To

Win XP, Win 7

PCT 6.8.1076

Attachments

Shell_Folders_issue_signed.7z get_app