Symantec Protection Engine (SPE) is unable to scan .mht files created by the Microsoft Windows Problem Steps Recorder application.

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Article ID: 157634

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Updated On:

Products

Protection Engine for Cloud Services Protection Engine for NAS

Issue/Introduction

Symantec/Protection Engine (SPE) is unable to scan .mht files created by the Microsoft Windows Problem Steps Recorder application.

SPE produces an unscannable error.

Cause

This is not an issue with Symantec Protection Engine as the .mht files produced by Windows Problem Step Recorder are malformed.

The issue with these files is that they do not contain a null line after the "boundary=" definition.  Because of this the preamble section of the file is interpreted as part of the message header which causes the file to be malformed.

Resolution

The current workaround is to disable malformed container detection in SPE.

To disable malformed container detection perform the following steps:

  1. Login to SPE console
  2. Go to Policies
  3. In the sidebar under Views, click Filtering.
  4. Click the "Container Handling" tab at the top of the page.
  5. Uncheck the "Enable Malformed Container Handling" checkbox
  6. Save and Apply changes