KNOWN ISSUE: Package Server Agent is unable to set file permissions on packages exceeding 256 characters

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Article ID: 157608

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Updated On:

Products

Management Platform (Formerly known as Notification Server)

Issue/Introduction

When a package server agent downloads a package with the character length of the locally saved path and file name exceeding 256 characters, the package server agent is unable to set the file security permissions.

 

Priority: 1
Date: 1/25/2013 2:48:20 PM
Tick Count: 687147375
Host Name: SiteServer
Process: AeXNSAgent.exe (1280)
Thread ID: 2896
Module: AeXNSCPackageServer.dll
Source: CFileSecurity
Description: Unable to get buffer length for SD of file 'C:<Long path and file name exceeding 256 characters>\file.txt' (123)


Priority: 1
Date: 1/25/2013 2:48:20 PM
Tick Count: 687147390
Host Name: SiteServer
Process: AeXNSAgent.exe (1280)
Thread ID: 2896
Module: AeXNSCPackageServer.dll
Source: CFileSecurity
Description: Unable to set security for file 'C:<Long path and file name exceeding 256 characters>\file.txt', Error:The filename, directory name, or volume label syntax is incorrect(123)

 

Cause

As of SMP 7.1 SP2 the Symantec Management Agent is capable of downloading files with a path depth longer than 256 characters.  The package server agent is unable to set file security permissions on files that exceed the traditional 256 character limit.

 

Resolution

A fix has been provided with our ITMS 7.1 SP2 MP1 Rollup v4. See HOWTO81832

However, for those Windows Server 2003 or Windows XP package servers, there is a step that is needed before this fix can work properly. The following steps need to be done only once for packages already created prior to this fix with this issue on your Windows Server 2003 or Windows XP package servers. After this, new packages will be able to apply the fix automatically:

1. Identify the package(s) with file name exceeding 256 characters.
2. Go to “Package Delivery” directory (under .../Program Files/Altiris/Altiris Agent) and delete the package Guid directory for the package(s) identified in step 1 above.
3. Clicked the “Refresh Packages” button in the 'Package Server tab' for the Symantec Management Agent.

The Package Server should be able to download the package again and the security will be set correctly. 


Applies To

Symantec Management Platform 7.1 SP2