Client's Altiris Agent GUI; Software Update Tab shows 'plug-in is not ready' after it has initially installed the Software Update Plug-in.

book

Article ID: 157560

calendar_today

Updated On:

Products

Patch Management Solution for Windows

Issue/Introduction

Rolled out the Software Update Plug-in and the client's Altiris Agent GUI; Software Update Tab shows 'The software update plug-in is not ready'

 

"1/15/2013 3:37:52 PM","Failed to create object Altiris.SoftwareUpdateAgent: The object is not registered or is not present in the policy (-2147467237)","Agent","AeXNSAgent.exe","8260"

Cause

Environment has been configured with a separate app pool for the Inventory Rule Management.

Resolution

Configure the separate app pool as follows:
  1. Right-click the separate App Pool > Properties > Performance tab.
  2. Ensure that the Limit the kernel request queue option is enabled and set to 1,000 (this is the default value for a clean install of IIS 6).
  3. Review complete configuration as detailed in KM: HOWTO4592 

Advisory: It is best practice to not have the separate app pool for the Inventory Rule Management in versions 7.1+, for the system runs on a different version of IIS than it did in versions 6.2 - 7.X.


Applies To

Patch Management 7.1, SP1, SP2 & MP1