Unable to upgrade Symantec Management Agent on systems with Altiris Recovery Solution agent installed

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Article ID: 157512

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Updated On:

Products

Management Platform (Formerly known as Notification Server)

Issue/Introduction

When the Altiris Recovery Solution agent is installed, the Symantec Management Agent fails to upgrade to the 7.1 SP2 MP1 version.

The AexNSC.log may indicate the following errors:

2012-12-06 08:56:10: Action DeleteFile (C:\Program Files\Altiris\Altiris Agent\x86\CENfySvrClient.tlb): error Access is denied.

or

2012-12-06 16:32:10: Action DeleteFile (C:\Program Files\Altiris\Altiris Agent\x86\AeXNSAgentHostSurrogate32.exe): error Access is denied.

Cause

The upgrade issue is duplicated most often when the Altiris Recovery Solution agent is installed.

Resolution

A pointfix has been provided by development for customers experiencing this issue.  Please contact Symantec Support to receive the pointfix file. 

 

MINIMUM REQUIREMENT
 
SMP 7.1 SP2 MP1 with Altiris Recovery Solution installed
 
HOW TO INSTALL THIS POINTFIX
 
1.     Retrieve files from the archive to the NS hard drive.
Make sure PointFix is not extracted to Altiris install directory (or any subfolder to it)
2.     Run as administrator PFinstaller.EXE, click on ‘Install files’ button
3.     Old binaries will automatically backup to the same location where PFinstaller is and replaced with the new ones.
4.    Use Symantec Management Agent upgrade policy to update SMA agent.
 
CHANGES MADE
Agent version 7.1.15405.8405
 
KNOWN ISSUES WITH THIS POINTFIX:
None.
 
HOW TO UNINSTALL
  1.  Make sure that Backup subfolder is located in PFinstaller’ directory
  2. Execute PFInstaller.exe with administrative privileges (right-click > Run as administrator).
  3. Accept UAC (User Account Control) prompt, select Uninstall Files.

 


Applies To

SMP 7.1 SP2