The prevention feature of SCSP is not working after a major upgrade to the Windows Operating System.

book

Article ID: 157458

calendar_today

Updated On:

Products

Critical System Protection

Issue/Introduction

The prevention feature of SCSP is not working after a major upgrade to the Windows Operating System.

No errors are seen

Cause

The SCSP prevention drivers installed on the system may not be compatible with the new Windows Operating System, thus preventing the drivers from working correctly.

Each version of the Windows Operating System requires that the correct set of SCSP drivers are installed that are compatible with the Windows Operating System in use. When the agent is installed, it determines the Windows Operating System being used and installs the correct set of SCSP drivers that are compatible with the Operating System. For example, when the Windows Operating System is upgraded from Windows 2008 to Windows 2012, the SCSP drivers that were formerly compatible with Windows 2008 will no longer be compatible with Windows 2012.

Note: This recommendation would apply to any Windows OS upgrade since there are different versions of SCSP drivers for different versions of Windows such as 2003, 2008, 2012, etc. This would also apply to both 32-bit and 64-bit versions of the Operating System.

Resolution

Uninstall the SCSP agent before performing the Windows Operating System upgrade, then after the OS is successfully upgraded, re-install the SCSP agent.


Applies To

SCSP agent is installed on a Windows Server.  Following the agent install, the Windows Server is now upgraded to a different version of the Windows Operating System.