Enterprise Security Manager; Agent registration error: csp__server_handshake: error reading version from client timed out waiting for data from server.

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Article ID: 157353

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Updated On:

Products

Control Compliance Suite Windows

Issue/Introduction

While registering an Enterprise Security Manager (ESM) agent to an ESM manager the registration fails with an timeout. You want to increase the timeout.

[06684] TCP server: 2012/10/08 15:51:29:866: Connect from xxx.xxx.xxx.xxx:42547 fd=480
[06684] TCP server: begin: 1349704289 diff: 10 end: 1349704299
[06684] TCP server: connection handshaking failed.
csp__server_handshake: error reading version from client
timed out waiting for data from server

Cause

Some networks require more time for the communication to be succesfull.

Resolution

Add the following variable to the ESM manager's System Properties:

ESM_SERVER_HANDSHAKE_READ_TIMEOUT = 60

Step1.

Right-Click on "my computer" and select properties - select the Advanced tab - click "Environment Variables"

 

Step 2.

Add a variable with the name: ESM_SERVER_HANDSHAKE_READ_TIMEOUT and the value of: 60 (default value is 10s).

 

Step 3. Restart the "Symantec ESM Manager" service  for the changes to take effect.

 


Applies To

Enterprise Security Manager 9.x, 10.x

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