CCS Agent registration error: csp__server_handshake: error reading version from client timed out waiting for data from server.
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Article ID: 157353
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Products
Control Compliance SuiteControl Compliance Suite Standards ModuleControl Compliance Suite Standards Server
Issue/Introduction
Control Compliance Suite (CCS)
While registering a CCS agent to a CCS manager, the registration fails with a timeout error similar to the error below:
[06684] TCP server: 2012/10/08 15:51:29:866: Connect from xxx.xxx.xxx.xxx:42547 fd=480 [06684] TCP server: begin: 1349704289 diff: 10 end: 1349704299 [06684] TCP server: connection handshaking failed. csp__server_handshake: error reading version from client timed out waiting for data from server
Cause
Some networks require more time for communication to be successful.
Resolution
To help resolve this issue, you can increase the timeout on the CCS Manager(s) to allow for more time to make the connection.
On each of the CCS managers, you will need to modify the C:\Program Files (x86)\Symantec\CCS\Reporting and Analytics\ESM\config\manager.conf file.
In the manager.conf file, find the ESM_SERVER_HANDSHAKE_READ_TIMEOUT parameter:
# ESM_SERVER_HANDSHAKE_READ_TIMEOUT # Specifies the timeout in seconds. Do not wait for handshake to be successful for more than specified seconds ESM_SERVER_HANDSHAKE_READ_TIMEOUT=30
Increase the value for the ESM_SERVER_HANDSHAKE_READ_TIMEOUT parameter from 30 (default value in seconds) to 60:
ESM_SERVER_HANDSHAKE_READ_TIMEOUT=60
Save the manager.conf file.
Stop and restart the Symantec CCS Manager and the Symantec Data Processing Service services for the new parameter to be applied to the manager.