Error: The specified UNC does not allow read/write access when validating Software Library folder
search cancel

Error: The specified UNC does not allow read/write access when validating Software Library folder

book

Article ID: 157265

calendar_today

Updated On:

Products

Software Management Solution IT Management Suite Client Management Suite

Issue/Introduction

When configuring the Software Library in IT Management Suite (ITMS), clicking the "Validate" button may result in an error stating the UNC does not allow read/write access. This occurs even when the Agent Connectivity Credential (ACC) has been granted read permissions, as the validation process specifically tests for write capabilities to ensure software packages can be managed correctly.

An error of "the specified UNC does not allow read/write access" is displayed after clicking the "Validate" button.

In addition, a similar error like the following may appear: 

WebApi Controller failure.
Access to the path '\\SMP Name\SoftwareLibrary\GUID' is denied.

Environment

ITMS 8.x

Software Management Solution 8.x

Cause

The Software Library validation tool requires the configured credential (typically the ACC or AppID) to have Read, Write, and Change permissions on the share and folder. If the account is restricted to "Read-Only" per security policies, validation will fail.

Resolution

Configure the Software Library by doing the following: 

  1. Create local user on the Notification Server (or use existing domain non admin user) to be used as the Agent Connectivity Credential
  2. Create new folder for “Software Library” in a location on the server desired (remote or local server)
  3. Right click on SW Library folder > Properties > click “Sharing” tab > click “Advanced Sharing” > click “Permissions”.  ADD local or domain user, and set Change and Read permissions. Click OK and save permissions.  
  4. Right click on SW Library folder > properties > click “Sharing” tab > click “Share…”  and ADD local or domain user and set “Read/Write” permissions > click Share, Done and Close
  5. Right click on SW Library folder > properties > click “Security” tab > click “edit” > Select the local or domain user > uncheck “Full control” permission > click OK to save changes
  6. Open Symantec Management Console > Settings > All Settings > > Agents/Plug-ins > Symantec Management Agent > Settings > Global Agent Settings > open “Authentication” tab > select "Use these credentials" and enter the local or domain user > save changes
  7. Open Symantec Management Console > Settings > All Settings > Software folder > Software Catalog and Software Library folder > Software Library Configuration.  Specify SW Library folder and click “Validate”.  If validation passes, then click “Save Changes”

 

Configure Distribution Point Credential (DPC) by doing the following:

NOTE: We recommend "Use Agent Connectivity Credential" option for the DPC instead of specifying an account credential for the DPC.  Enabling Access to a Package at a UNC Source Location

  1. Specify the DPC by going to Settings > Notification Server > Notification Server Settings, and selecting the Distribution Point Credential tab:

 

Additional Information