KNOWN ISSUE: 'Report Data Snapshot Purging' tab is not loading correctly

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Article ID: 157170

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Updated On:

Products

Management Platform (Formerly known as Notification Server)

Issue/Introduction

The customer reported issues while he is trying to open the "Report Data Snapshot Purging" tab for the Purging Maintenance page. In his case this tab loads but it is missing text on the page.

Module: w3wp.exe
Source: Altiris.NS.UI.Admin.Configuration.cfgPurgeReportsCtrl.OnLoad
Description: Altiris.DataSource.Exceptions.DataSourceQueryResolveException
caught in OnLoad. Reason: Failed to resolve resource query from the xml configuration.


( Exception Details:
Altiris.DataSource.Exceptions.DataSourceQueryResolveException: Failed to resolve resource query from the xml configuration. --->
Altiris.NS.Exceptions.AeXException: This join source does not have a dataField '_ResourceGuid'

 

Cause

Known Issue. In this particular instance the problem was caused by a bad report xml. When the Purging Maintenance page is trying to load, it goes over the reports in use and if one of them has an issue then the page doesn't render properly.

Resolution

This issue has been reported to the Symantec Development Team. A fix will be provided in a later release.

There is a pointfix available for this issue. The pointfix fixes:
a) Labels rendering, 
b) Error reporting panel moved to the top of the screen,
c) Improved page loading performance.

Please see attachment called "Pointfix_eTrack2932455.zip"

MINIMUM REQUIREMENT:

Installed ITMS 7.1 SP2 with Rollup v4 (See HOWTO64413)

HOW TO INSTALL THIS POINTFIX:
1. Extract files from the archive to the NS hard drive. Make sure PointFix is not extracted to Altiris install directory (or any subfolder to it).
2. Execute Install.cmd with administrative privileges (right-click > Run as administrator).
3. While PF installation, old files will be automatically copied to the PointFix’ subfolder ‘Backup’.
4. Data about rollup will be placed into registry under HKEY_LOCAL_MACHINE\SOFTWARE\Altiris\Pointfixes
 

THIS HOTFIX HAS THE FOLLOWING KNOWN ISSUES:
None.

HOW TO UNINSTALL THIS POINTFIX:
1. Make sure that Backup subfolder is located in PFinstaller’ directory
2. Execute Restore.cmd with administrative privileges (right-click > Run as administrator).
3. Assemblies will be restored from the ‘Backup’ folder
4. Close PFInstaller window.
 

 

Note: In some cases these bad reports or datasources can be hidden (the NS logs should tell you the name of the report that is causing the issue). Grab the GUID for the report and replace it in this link:
http://YOURNSNAME/Altiris/NS/ItemPropertiesNS7.aspx?view=properties&ItemGuid=REPLACEGUIDHERE&ConsoleGuid={3faa8b67-250b-42ad-8186-fe2f49a9e707

It should tell you where the report resides in the tree. If it is hidden, then you can use the following query to change the hidden attribute to visible:

update Item 
set Attributes = 0 
where Guid = 'REPORTGUIDGOESHERE'

After that you should be able to find it in the tree and delete it.


Applies To

Symantec Management Platform 7.1 SP2

Attachments

Pointfix_eTrack2932455.zip get_app