After upgrading Symantec Messaging Gateway to version 10.0.0-7 the MTA service can not start

book

Article ID: 157146

calendar_today

Updated On:

Products

Messaging Gateway

Issue/Introduction

After upgrading Symantec Messaging Gateway (SMG) to version 10.0.0-7 the MTA service can not start.

Symptoms
- The hardware is supported
- There is enough disk space
- The upgrade completes successfully
- There are no other appearent issues
- Rebuilding the rpm database does not help
- Reboot does not help
- When trying to start the MTA an error "Bareword found where operator expected at /opt/Symantec/Brightmail/mta/lib/perl/Term/readPassword.pm line 7, near "VEOF VEOL" is displayed

 

From BrightmailLog.log:
[BrightmailScheduler_Worker-48] ERROR - Cannot obtain the pause mode status. 
[BrightmailScheduler_Worker-48] ERROR - Bareword found where operator expected at /opt/Symantec/Brightmail/mta/lib/perl/Term/ReadPassword.pm line 7, near "VEOF VEOL" (Do you need to predeclare VEOF?)
syntax error at /opt/Symantec/Brightmail/mta/lib/perl/Term/ReadPassword.pm line 7, near "VEOF VEOL "Compilation failed in require at /usr/lib/perl5/vendor_perl/5.8.8/SMS/Common.pm line 59
BEGIN failed--compilation aborted at /usr/lib/perl5/vendor_perl/5.8.8/SMS/Common.pm line 59
Compilation failed in require at /opt/Symantec/Brightmail/mta/lib/perl/SMS/MTA.pm line 59.

 

Cause

A corruption has occured to the MTA during the upgrade process

 

Resolution

Symantec is currently investigating the issue. Currently the only solution is OSRestore. Pls subscribe to this article for future updates.

 


Applies To

SMG 9.5.x
SMG 10.0.x