Unable to add a Scan Engine to Protection for Sharepoint Servers

book

Article ID: 157142

calendar_today

Updated On:

Products

Protection for SharePoint Servers

Issue/Introduction

You try to add a Scan Engine to the Protection for Sharepoint Servers console but when you click Next, nothing happens

When you review SPSS' system log (by default, this is C:\Program Files\Symantec\SharePoint\Logfiles\), you find the following entry:

"2012-10-02 14:36:39","(null)","-1","Error","No connection could be made because the target machine actively refused it x.x.x.x:9455"," 
Server stack trace:     at System.Net.Sockets.Socket.DoConnect(EndPoint endPointSnapshot, SocketAddress socketAddress)
    at System.Net.Sockets.Socket.Connect(EndPoint remoteEP)
    at System.Runtime.Remoting.Channels.RemoteConnection.CreateNewSocket(EndPoint ipEndPoint)
    at System.Runtime.Remoting.Channels.RemoteConnection.CreateNewSocket()
    at System.Runtime.Remoting.Channels.SocketCache.GetSocket(String machinePortAndSid, Boolean openNew)
    at System.Runtime.Remoting.Channels.Tcp.TcpClientTransportSink.SendRequestWithRetry(IMessage msg, ITransportHeaders requestHeaders, Stream requestStream)
    at System.Runtime.Remoting.Channels.Tcp.TcpClientTransportSink.ProcessMessage(IMessage msg, ITransportHeaders requestHeaders, Stream requestStream, ITransportHeaders& responseHeaders, Stream& responseStream)
    at System.Runtime.Remoting.Channels.BinaryClientFormatterSink.SyncProcessMessage(IMessage msg)  Exception rethrown at [0]:
     at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)
    at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)
    at Symantec.Sharepoint.Shared.InterfaceLibrary.IRTCommandService.GetSPSSEnabledServerFromDb(String serverName)
    at Symantec.Sharepoint.RTCommandClient.RTCommand.InitService(String spssMachine)
    at Symantec.Sharepoint.RTCommandClient.RTCommand.AbortAllScans(String spssMachineName)","mscorlib","RTCommandClient"

Cause

This is caused by not having open communication on all ports needed for SPSS to talk to the Central Admin server

Resolution

Be sure that all firewalls are allowing ports 9455, 9466, and 9477 between the SharePoint servers. Also make sure that port 1344 is open to the IP address of the Scan Engine server.