BUG REPORT: message "group membership queue service is disabled in global pref" on Symantec Encryption Management Server (previously PGP Universal Server) after upgrade.

book

Article ID: 156973

calendar_today

Updated On:

Products

Encryption Management Server Gateway Email Encryption

Issue/Introduction

Fresh installs of PGP Universal server versions 3.0.0 and 3.1.2 are missing the <groupd> and <pgpsyncd> sections in configuration file /etc/ovid/prefs.xml. Upgrading such a version via PUP update file does not add the missing sections.

These sections are present on a fresh 3.2.x. install.

If this section is missing after upgrading to 3.2 a message (of the severity "Notice") is issued.

This is a minor issue that doesn't affect functionality (this applies to all message levels up to "warnings"). If these sections are missing the default values will be used instead.
Although there should not be any technical impact it was reported that the missing sections caused performance issues in environments with large directories and not all users from the directory were visible in the user section.

 

After an upgrade of a 3.0 or 3.1.2 server to 3.2  the message "group membership queue service is disabled in global pref" is shown in the "Groups" log..

 

Cause

The sections <groupd> and <pgpsyncd> are not present on a fresh install of PGP Universal 3.0.0 (Build 2881) or 3.1.2 (Build 50) and might not be added when migrating to 3.2.x.

The option <group-membership-optimization>false</group-membership-optimization> in configuration file /etc/ovid/prefs.xml is set to "False" or missing.

 

Resolution

This issue is fixed in the following release:

  • Symantec Encryption Management Server 3.3.2 MP1 (Build 15337) and above

For a full list of resolved issues in Symantec Encryption Management Server 3.3.2 including all Maintenance Packs (MP) please check http://www.symantec.com/docs/TECH164863

This version/Maintenance Pack is available for download via your account on Symantec File Connect - https://fileconnect.symantec.com

 


Applies To

Symantec Encryption Management Server 3.0.0 or PGP Universal Server 3.1.2 installed from ISO upgraded to 3.2.x or above.

 

Attachments