Deployment Automation Folder for Windows (x64) will not work on Japanese OSs
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Deployment Automation Folder for Windows (x64) will not work on Japanese OSs

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Article ID: 156943

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Updated On:

Products

IT Management Suite

Issue/Introduction

It has been seen in some environments that using the Automation Folder will not work and when doing the following:

1. Login to Console
2. Select "Actions" tab
3. Navigate "Deployment" -> "Install Automation Folder" -> "Windows (x64)"

Then you will encounter such an error, which states:

= quote =
No Package could be found for the selected Agent policy
= unquote =

This does not occur neither with "Windows (x86)" nor "Linux (x86)" amd it's limitted only to "Windows (x64)".

No Package could be found for the selected Agent policy

Environment

ITMS 8.x

Cause

This does not happen in English OS and is only observed in the Japanese OS.

Resolution

There is a workaround for this issue and application procedure is as follows:

Repeat procedure described below against the XML files exactly as the following list order:

+ XML files (please refer to attachment)

1. "Deployment Automation Folder for Windows (x64) - Install.xml" 
2. "Deployment Automation Folder for Windows (x64) - Uninstall.xml" 
3. "Deployment Automation Folder for Windows (x64) - Upgrade.xml" 
4. "Deployment Automation Folder (x64).xml"  

+ procedure 

$ cd C:\2Inst 
$ move "Deployment Automation Folder for Windows (x64) - Install.xml" tmp.xml 
$ sed -e "s/DS71SP2/newHost/g" tmp.xml > "Deployment Automation Folder for Windows (x64) - Install.xml" 

$ cd C:\Program Files\Altiris\Notification Server\Bin\Tools 
$ ImportExportUtil.exe /import "C:\2Inst\x64\Deployment Automation Folder for Windows (x64) - Install.xml"

Attachments

xml.zip get_app