The software update fails with the error: "Err Inappropriate ioctl for device" due to unmet dependencies

book

Article ID: 156935

calendar_today

Updated On:

Products

Messaging Gateway

Issue/Introduction

You have initiated a software update on the Symantec Messaging Gateway, however the update fails with the error "Err Inappropriate ioctl for device" reported. There is a reference to "unmet dependencies" in the update log.

The update log will show the following ->

You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
  compat-libstdc++-33: Obsoletes: compat-libstdc++ but 7.3-2.96.118 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
Err Inappropriate ioctl for device

Cause

The Messaging Gateway is trying to download a package that is older than the package already installed, this is possibly due to a failed removal of the existing package.

Resolution

Please contact Symantec Enterprise Support for further assistance (referencing this article).