Clients fail to return Patch Inventories when targeted by a cloned Windows System Assessment Scan.

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Article ID: 156932

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Updated On:

Products

Patch Management Solution for Windows

Issue/Introduction

Created a clone of the Windows System Assessment Scan and found clients now fail to return Patch Management Inventories and update database for review in Compliance Reports.

Cause

The default GUID for the Windows System Assessment (WSAS) scan is referenced by Patch Management reporting, for it is associated with the dataclasses of Patch Management.

When the WSAS is cloned; a new GUID is created for this policy. The cloned WSAS GUID is not associated with these dataclasses and is unable to return Patch Inventories for processing to the database.

Resolution

It is not best practice to clone the Windows System Assesment Scan policy for PM 7.1 SP1 & SP2, for it has been found to cause problems processing Patch Inventories in some environments.

If performance is needed to be increased; configure the scan interval to run loosely around every 6-8 hours.

  • Note: the default filter for this policy: 'Windows Computers with Software Update Plug-in Installed Target'

However, the cloning process; separating schedules for different filters to run the Windows System Assessment Scan (WSAS) has been tested and confirmed working as designed in PM 7.1 SP2 MP1+. Ensure the default policy no longer targets the clients that will be targeted by the cloned policies to ensure they only receive one WSAS Policy.


Applies To

Patch Management 7.0, 7.1, SP1 & SP2.