Control Compliance Suite (CCS) Data Collection for Unix asset fails with error 'An error occurred while creating RMS scopes'

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Article ID: 156921

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Updated On:

Products

Control Compliance Suite Exchange Control Compliance Suite Unix Control Compliance Suite Windows

Issue/Introduction

CCS Data collection jobs and Ad-hoc queries fail for Unix asset(s).

Error in CCS Console (UI): Unix Data Collector: An error occurred while creating RMS scopes. Object reference not set to an instance of an object.

Error in CCS Manager's WorkerProcess logs:

An error occurred while retrieving collector configuration. Failed to resolve component reference http://www.symantec.com/CSM/Components/DataCollectors/Unix.

Or

An error occurred while retrieving collector configuration. Failed to resolve component reference http://www.symantec.com/CSM/Components/DataCollectors/Unix/ScopeGeneration.

Cause

There are two possible scenario's for this error to show.

Scenario 1


In case you have multiple CCS managers and queries for UNIX asset(s) are routed through these various CCS Managers using Routing Rules to perform data collection jobs. The job workflow expects legacy architecture identified by legacy configuration component registration. By default the legacy component registration is not set and thus this error shows.
 

Scenario 2

In this scenario with only one CCS manager in place and no routing rules defined, the cause of this issue is that in the CCS console, the  "Settings -> General -> Application configuration -> Agents -> Enable import and upgrade of BV-Control for UNIX agents" setting was checked and then unchecked again.

 

Resolution

Solution for scenario 1 & 2;

To enable the legacy configuration component registration,


1.    Open Symantec CCS Console
2.    Go to > Settings > General
3.    Select Agents under Application Configuration section
4.    Check option Enable import and upgrade of BV-Control for UNIX agents
5.    Go to > System Topology > Map View
6.    Click Infrastructure Tasks and select Sync Configuration

 

Alternative solution for scenario 2;

Although enabling the checkbox again "fixes" the issue (as per the solution for scenario 1) - it is not be necessary to do so. There is a way to re-register the UNIX type platform without having to check the checkbox. Here are the steps to do this:

1. Make sure the "Settings -> General -> Application configuration -> Agents -> Enable import and upgrade of BV-Control for UNIX agents" setting is unchecked.
2. Go to "Settings - > System Topology -> Infrastructure Tasks" and "Sync Configuration"
3. open up a command prompt
4. change directory into : {drive:}\Program Files (x86)\Symantec\CCS\Reporting and Analytics\Application Server>
5. run the following command: {drive:}\Program Files (x86)\Symantec\CCS\Reporting and Analytics\Application Server>CCSUtil.exe register /File=RegistrationXMLs\UnixDataCollector.Component.Registration.Xml /force=true /save
6. Go to "Settings - > System Topology -> Infrastructure Tasks" and "Sync Configuration"

Now run a UNIX type Ad-hoc query or data collection - at this point it will work without having checked the "Enable import and upgrade of BV-Control for UNIX agents" checkbox nor will it give the error message again in a single CCS manager, no routing rule scenario.


 

 

Applies To

 

CCS 11.0 (11.0.546.10000) <= PU 2012-1 (.10100)