Unable to update Symantec Messaging Gateway scanner; update fails with rpmdb version mismatch error

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Article ID: 156908

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Updated On:

Products

Messaging Gateway

Issue/Introduction

Unable to update Symantec Messaging Gateway (SMG) scanner from the Control Center interface or CLI. Attempting to update the SMG scanner results in an error indicating an RPM database environment and version mismatch. Following the failed update, attempting to view the scanner's configuration in the Control Center GUI results in an application error.

rpmdb: Program version 4.3 doesn't match environment version
error: db4 error(-30974) from dbenv->open: DB_VERSION_MISMATCH: Database
environment version mismatch
error: cannot open Packages index using db3 -  (-30974)
error: cannot open Packages database in
E: could not open RPM database
(repeats)

Cause

An update to one of the underlying packages has returned an incorrect status code and the scanner failed to reboot.

Resolution

When updating a scanner from a release prior to version 9.5.2, which was also initially installed with version 4.1.x, you will need to manually reboot the scanner after the upgrade is complete. Following the reboot, the update will complete and the scanner will again be accessible from the Control Center GUI.