Error in client logs on PGP Universal Server: Invalid domain name specified

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Article ID: 156891

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Updated On:

Products

Symantec Products

Issue/Introduction

 

Error in client logs on PGP Universal Server: Invalid domain name specified

 

2012/05/16 14:14:03 -04:00 ERROR pgp/client[23889]:     CLIENT-00003: get key 
by keyid failed: Invalid domain name specified

Cause

 

This error is a result of key lookups being performed for individual users in which the email address is not resolved against the Managed Domains listed on PGP Universal Server. This error is especially prone to appearing in PGP Whole Disk-Only environments, due to the fact that WDE-Only users do not typically have an email address associated to the PGP Key that was created, and would cause a problem associating the domain to the key.
This is associated to the keyserver “keys.$ADDRESS_DOMAIN” located on the Keyserver list of PGP Universal Server.
Key lookups are performed in the background on every client connection, therefore, each time a PGP Desktop client communicates with the Universal Server, this error may be displayed.
The error does not appear to cause any actual problems with the PGP software, however it does cause confusion and concern.

 

Resolution

 

This issue has been resolved in PGP Universal Server 3.2.1 MP5 and above and will no longer produce this type of warning in the client logs.
 

Applies To

This error may appear after upgrading to PGP Universal Server 3.2.