Unable to select/add "Product key" after selecting an image on a Deploy Image task

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Article ID: 156826

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Updated On:

Products

Deployment Solution

Issue/Introduction

If you try to create a "Deploy Image task", you can't save it until you select a license number (Product Key) for the image.  However, the list doesn't populate.  Even if you click "new" and enter a license you know is valid, you still don't get anything on the drop list. Drop list is blank


 

Cause

The issue is caused because the 'OStype' of the image that is stored in 'Inv_image_resource_component' is set to 'unknown'.  There are two side effects to this:

  1. 'Product Key' cannot be selected
  2. The contents of the unattend.xml file is not read into the task.   Without this data in the XML of the task, the default unattend.xml file in the image will be used by minisetup.

Resolution

If you are sure that image is properly sysprepped and you have valid license then run the query in database

Open  SQL Management Studio, select your Symantec SMP database and then Run following Query

select *
  from Inv_Image_Resource_Component

This will give you information about images, resource guid and OS type. In some cases, the "OS Type" field will be blank, or show "Unknown".  This is one of the reasons for blank drop list for license key.

Here we need to change the OS Type from unknown  to its original name. Run the following query

update Inv_Image_Resource_Component
   set ostype = 'Windows 7'
 where ostype = 'unknown'
   and _resourceguid = '<resource guid of imag
e>'

Then try to create the deploy job. You should get license key to select for that image.

Note: For Windows 10 images you would set the 'ostype'='Windows 10'.  Other operating systems follow the same example. (XP, 8, 8.1 etc)

Alternate Workaround

Capture a new image to use for deployment.  This will create a new Product Key association with the new image that will be available in the Product Key drop down of the Deploy Image job.