Viewing dashboard panels in Control Compliance Suite (CCS) Web Portal generates error: There was an error processing the request.

book

Article ID: 156812

calendar_today

Updated On:

Products

Control Compliance Suite Exchange Control Compliance Suite Windows

Issue/Introduction

When specific user (i.e. CCS Administrator) selects Dashboard > Panels view in CCS Web Portal an error is thrown and user cannot view Panels list.

Cause

A missing record in Dashboard.DashboardPanel for a user-created (CCS Administrator) panel caused the CCS Web Portal to generate error in Web Portal log:

Csla.DataPortalException: DataPortal.Fetch failed (Error fetching all panels. Object reference not set to an instance of an object.

Resolution

Please contact Symantec Support.

NOTE: Support will need to create a custom SQL script to remove user-specific panel records in CSM_Reports database that reference missing record in Dashboard.DashboardPanel table.


Applies To

Control Compliance Suite 11.0.546.10000
 

Attachments