Enterprise Security Manager (ESM) agent, fails to install Redhat Enterprise 6.x (x86_64)

book

Article ID: 156649

calendar_today

Updated On:

Products

Control Compliance Suite Unix Control Compliance Suite Windows

Issue/Introduction

When you try to install an ESM or CCS Agent on 64 bit version (x86_64) of Redhat Enterprise 6.x it fails.

lib/ld-linux.so.2: bad ELF interpreter No such file or directory

Cause

The default install of Redhat 6.x 64 bit version does not install the 32 bit libraries required by the agent to install.

Resolution

The following rpm packages need to be installed off the Redhat Installation Media.

Please note: the exact version numbers may be different depending on what release of Redhat you are using. Replace * with the package shipped with your version:

glibc-2.12.*.el6.i686.rpm
nss-softokn-freebl-3.12.*.el6.i686.rpm

If doing ESM type message based policies, and using the account integrity or password strength modules, the following packages will also be needed:

pam-1.1.*.el6.i686.rpm
audit-libs-2.1.*.el6.i686.rpm
cracklib-2.8.*.el6.i686.rpm
db4-4.7.*.el6.i686.rpm
libselinux-2.0.*.el6.i686.rpm

Please note: For the agent to function properly please do not remove redhat-release-server-6Server-*.el6.x86_64.rpm. This package is necessary for the agent to detect which version of redhat is installed.