Unable to get the database schema version when upgrading SEPM EE from 12.1 RU1 to 12.1 RU1 MP1

book

Article ID: 156605

calendar_today

Updated On:

Products

Endpoint Protection

Issue/Introduction

Unable to upgrade SEPM from 12.1 RU1 to 12.1 RU1 MP1

Unable to get the database schema version. You must ensure that the database server is working and can be connected to from the Management Server.

Event ID : 1, Source : SQLANY 11.0

SQLANYs_sem5: Database cannot be started - - sem5.log is an invalid transaction log

 

Error in Event Viewer

Cause

Embedded Database Service not getting started.

Resolution

1) Stop the Symantec Endpoint Protection Manager and Symantec Embedded Database services. 
2) Rename or delete the current sem5.log
3) Click Start Run and type CMD then click OK 
4) In the Command Prompt type:
    For 32-bit: CD C:\Program Files\Symantec\Symantec Endpoint Protection Manager\ASA\win32\
    For 64-bit: CD C:\Program Files (x86)\Symantec\Symantec Endpoint Protection Manager\ASA\win32\
5) Press Enter. This will change directories to the folder containing dbsrv11.exe. 
6) To force the recreation of sem5.log, type:
    For 32-bit: dbsrv11 -f "C:\Program Files\Symantec\Symantec Endpoint Protection Manager\db\sem5.db"      (There is a space after -f and "C:\...)
    For 64-bit: dbsrv11 -f "C:\Program Files (x86)\Symantec\Symantec Endpoint Protection Manager\db\sem5.db"     (There is a space after -f and "C:\...)
7) Press Enter
8) Click Start > Run and type services.msc then click OK
9) Start the Symantec Endpoint Protection Manager and Symantec Embedded Database services.

After performing the steps given above, try to upgrade the SEPM, it should complete successfully.


Applies To

1 SEPM on Windows Server 2008 R2 Enterprise Edition 64bit

Embedded Database

SEPM on 12.1 RU1

Attachments