Symantec RMS Process Manager Service fails to stay started. When restarted, it runs for about a second then shuts down again.

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Article ID: 156498

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Updated On:

Products

Control Compliance Suite Windows

Issue/Introduction

 Symantec RMS Process Manager Service fails to stay started. When restarted, it runs for about a second then shuts down again.

There is no error while trying to start the service. The service starts and then stops. In the event log, following errors are displayed.

Event ID: 25
Event Source: BVProcessManager
Message: The SQL script executor OSQL.EXE reported an error.

Event ID: 6
Event Source: BVProcessManager
Error: Incorrect Function

Event ID: 62
Event Source: BVProcessManager
Error: System initialization failed.

Cause

This could be because the BVProcessManager Service is not able to connect to the local 'BV' database in MS SQL Server. Either the 'BV' database could be missing or access to it may be restricted.  

Resolution

Use the following checklist to resolve the issue:

  • BVPMServer user account is member of 'BV Console Admins', 'BV Console Users' & 'Administrators' groups on Information Server.
  • MS SQL Service (related to the instance on which BV database is installed) is Running.
  • BV Database is available.
  • If SQL service is running and BV database is available, then check under BV Database>> Security >> Users >> 'BV Console Admins' and 'BV Console Users' are available.
  • The Display names in MS SQL for the roles should be exactly as above and not as “Servername\Username”. If it is not so, then delete the user and add it again.
  • Rights required for 'BV Console Admins'
    • Owner of It’s own schema
  • Rights required for 'BV Console Users'
    • Owner of it’s own schema
    • Database role membership: BV_Users, db_datareader