Symantec Management Agent Install fails using Scheduled Push to Computers
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Symantec Management Agent Install fails using Scheduled Push to Computers

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Article ID: 156438

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Updated On:

Products

IT Management Suite

Issue/Introduction

Pushing the Symantec Management Agent to discovered windows computer individually selecting computers through "Rollout Agent to Computers" completes successfully, however the Scheduled Push to computers does not work.

NS logs (a.log) report:

"Unable to push agent to newly discovered machines.  The key 'NS.ClientCredentials' does not exist."

Environment

ITMS 8.x

Cause

The file NS.ClientCredentials.kms is missing from C:\programdata\symantec\smp\kms directory on SMP Server.

Resolution

In this case the issue is a missing KMS key.

The following KB will help to restore your KMS keys:

"Backing up and restoring Notification Server KMS encryption keys" (174996)