Is the VMware vSphere collector 4.4 compatible with ESX 5.0

book

Article ID: 156408

calendar_today

Updated On:

Products

Security Information Manager

Issue/Introduction

The collector logs an error when attempting to connect to the ESX Server.

WARN 2012-05-07 11:11:06,133 Collectors.3527.wGroup.[workinggroup0].SensorThread Thread-4391 [Sensor: USADANASINF01] Exception in Sensor thread while reading device. Details:

java.rmi.RemoteException: Exception in WSClient.invoke:; nested exception is:

java.lang.NullPointerException

at com.vmware.vim25.ws.WSClient.invoke(WSClient.java:157)

at com.vmware.vim25.ws.VimStub.readNextEvents(VimStub.java:2315)

at com.vmware.vim25.mo.EventHistoryCollector.readNextEvents(EventHistoryCollector.java:61)

at com.symantec.cas.ucf.sensors.vmware.VMwareSensor.readDevice(VMwareSensor.java:248)

at com.symantec.cas.ucf.collector.SensorJob.pollSensor(SensorJob.java:212)

at com.symantec.cas.ucf.collector.SensorJob.run(SensorJob.java:292)

at java.lang.Thread.run(Thread.java:662)

Caused by: java.lang.NullPointerException

 

Resolution

As long as the Symantec Event Collector for VMware vSphere, the vSphere Collector Sensor, and the Universal Collector Framework are LiveUpdated completely, ESX 5.0 is supported.

Support for ESX 5.0 was added in LiveUpdate June 2012.


Applies To

ESX 5.0