Performing a Collector runliveupdate.bat results in the error "ClassNotFoundException"

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Article ID: 156233

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Updated On:

Products

Security Information Manager

Issue/Introduction

Performing a Collector runliveupdate.bat results in the error "ClassNotFoundException" with addition errors such as "Could not find the main class: com.symantec.cas.ucf.liveupdate.InvokeJavaLiveUpdate.  Program will exit."  How do I resolve this issue?

"ClassNotFoundException"
"Could not find the main class: com.symantec.cas.ucf.liveupdate.InvokeJavaLiveUpdate.  Program will exit."

 

Cause

The cause is unknown at this time

Resolution

1. From the Start menu, locate the "Command Prompt", right click and run as administrator.

2. Within the command prompt, change directories to the collector C:\Program Files (x86)\Symantec\Event Agent\collectors\<name of collector>.  Uninstall the collector using "uninstall.bat".

3. Install the JLU Offbox JLU Updater afterwards (Not needed if using 4.7.1 Agent).

4. Download the product collector from https://fileconnect.symantec.com/ then Install it from the administrator command prompt. (example: ..<extracted_product_collector_folder>/install/install.bat)

5. When asked to perform a LiveUpdate, type "y" and press enter.  Observe that the sequence numbers are updating this time and that no errors are seen.

NOTE: If one runs into a return code 243 on the Framework update, close the administrator command prompt, attempt an uninstall of the collector and reinstall.  Doing this resolved that issue.  The error translate to "Java LiveUpdate was already running on the machine when this session started".  At the time, there were no other liveupdates running.


Applies To

Offbox SIM Agent 4.7.0
Version 4.4 of a Product Event Collector.  In this case it is Microsoft Windows Vista Event Collector 4.4
JLU Offbox Update allready applied