Error 1935 while installing Symantec Mail Security for Microsoft Exchange (SMSMSE): An error occurred running the installation of assembly 'Microsoft.VC90.ATL,version="9.0.30729.1"

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Article ID: 156101

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Updated On:

Products

Mail Security for Microsoft Exchange

Issue/Introduction

 

While running the SMSMSE installer a dialog box displays the following error message:

Error 1935. An error occurred during the installation of assembly ''Micrsoft.VC90.ATL,version="9.0.30729.1",publicKeyToken="1fc8b3b9a1e18e3b",processorArchitecture="amd64",type="win32".Please refere to Help and Support for more information. HRESULT: 0x8007007E

The last message displayed in the SMSMSE installer slideshow is Registering Product Information. The installation rolls back and SMSMSE is not installed.

 

  • Windows Component Based Service log (default location %windir%\logs\cbs\cbs.log) shows the following error sequence:

2012-03-16 18:53:14, Info                  CSI    00000006 Performing 3 operations; 3 are not lock/unlock and follow:
  Stage (1): flags: 8 app: [Microsoft.VC80.ATL, Version = 8.0.50727.42, pA = PROCESSOR_ARCHITECTURE_AMD64 (9), Culture neutral, VersionScope neutral, PublicKeyToken = {l:8 b:1fc8b3b9a1e18e3b}, Type = [l:10{5.EN_US}]"win32", TypeName neutral, PublicKey neutral]) comp: Microsoft.VC80.ATL, Version = 8.0.50727.42, pA = PROCESSOR_ARCHITECTURE_AMD64 (9), Culture neutral, VersionScope neutral, PublicKeyToken = {l:8 b:1fc8b3b9a1e18e3b}, Type = [l:10{5.EN_US}]"win32", TypeName neutral, PublicKey neutral man: @0x1082e18
  StageFile (2): flags: 8 app: [Microsoft.VC80.ATL, Version = 8.0.50727.42, pA = PROCESSOR_ARCHITECTURE_AMD64 (9), Culture neutral, VersionScope neutral, PublicKeyToken = {l:8 b:1fc8b3b9a1e18e3b}, Type = [l:10{5.EN_US}]"win32", TypeName neutral, PublicKey neutral]) comp: Microsoft.VC80.ATL, Version = 8.0.50727.42, pA = PROCESSOR_ARCHITECTURE_AMD64 (9), Culture neutral, VersionScope neutral, PublicKeyToken = {l:8 b:1fc8b3b9a1e18e3b}, Type = [l:10{5.EN_US}]"win32", TypeName neutral, PublicKey neutral file: [ml:20{10.EN_US},l:18{9.EN_US}]"ATL80.dll" srcfile: @0x1082f38
  AddCat (14): flags: 0 catfile: @0x1083058
2012-03-16 18:53:14, Info                  CSI    00000007 Creating NT transaction (seq 1), objectname [6]"(null)"
2012-03-16 18:53:14, Info                  CSI    00000008 Created NT transaction (seq 1) result 0x00000000, handle @0x240
2012-03-16 18:53:15, Info                  CSI    [email protected]/3/16:18:53:15.816 CSI perf trace:
CSIPERF:TXCOMMIT;875136
2012-03-16 18:53:15, Info                  SXS    Submitting install transaction
2012-03-16 18:53:15, Error                 CSI    [email protected]/3/16:18:53:15.818 (F) d:\longhorn\base\wcp\primitiveinstallers\settingsinstaller.cpp(225): Error STATUS_DLL_NOT_FOUND originated in function LoadSMIPrimitiveInstaller expression: ::LdrLoadDll(0, 0, &UNICODE_STRING_smiPI_dll, phSmiPiDll)
[gle=0x80004005]
2012-03-16 18:53:30, Error                 CSI    0000000b (F) HRESULT_FROM_WIN32(ERROR_MOD_NOT_FOUND) #865# from Windows::COM::CComponentStore::InternalTransact(...)[gle=0x8007007e]

  •  There is file corruption in the operating system

1. Download and run the Microsoft System Update Readiness Tool on the computer. 
2. Open the file %windir%\logs\cbs\CheckSUR.log in an editor.
3. The end of the file contains non-zero numbers of errors found, like this:

Summary:
Seconds executed: 3247
 Found 13293 errors
 Fixed 6382 errors
  CSI Payload File Missing Total count: 8259
  Fixed: CSI Payload File Missing.  Total count: 1348
  CSI SP File Not Yet Pre-Installed Total count: 57
  Fixed: CSI SP File Not Yet Pre-Installed.  Total count: 57
  CSI Store Directory Missing Total count: 4977
  Fixed: CSI Store Directory Missing.  Total count: 4977

This shows that there is file system corruption in the operating system.

NOTE: If there are no problems the log looks like this:


=================================
Checking System Update Readiness.
Binary Version 6.1.7601.21645
Package Version 14.0
2012-03-22 06:04

Checking Windows Servicing Packages
Checking Package Manifests and Catalogs
Checking Package Watchlist
Checking Component Watchlist
Checking Packages
Checking Component Store

Summary:
Seconds executed: 897
 No errors detected
(w)    Unable to get system disk properties    0x0000045D    IOCTL_STORAGE_QUERY_PROPERTY    Disk Cache   

 

Cause

The SMSMSE installer is unable to install the Microsoft Visual C++ 2008 SP1 Redistributable binaries. These libraries are packaged into the SMSMSE installer.  During the "Registering Product Information" section of the install process the SMSMSE installer "finalizes" the installation of the Microsoft runtime libraries.  This finalization may include updates to the Windows Side-by-Side library configuration.  In this case the installer is failing while updating the Windows Side-by-Side library configuration.

This is typically the result of missing or corrupt files in the operating system.

 

Resolution

It is necessary to resolve the operating system missing files or corrupted files.  It is recommended to contact Microsoft on the best resolution method. 

Here are some ideas:

 

Technical Information

Installer Cleanup

After the installer rolls back certain items from SMSMSE are not uninstalled:

Services
Web Site
IIS Application Pool

If the installer is run again immediately after this issue different errors occur. 

Perform the following steps to remove the remaining items before running the installer again:

1. Open a command prompt and run the following command to remove the service:

sc delete smsmse

2. Remove IIS component

a. Open Start|Administrative Tools|Computer Management.
b. Navigate to Services and Applications > Internet Information Services.
c. On the right hand side menu expand Server Name > Sites.
d. Right click Symantec Mail Security for Microsoft Exchange and select Remove.
e. On the right hand side menu expand Server Name > Application Pools.
g. Right click on SMSMSEAppPool and select Remove.

NOTE:  If the installer runs and there are errors other than the 1935 error it is recommended to go through manual uninstall steps using this article: Manual removal instructions for Symantec Mail Security for Microsoft Exchange, Symantec AntiVirus/Filtering for Microsoft Exchange, or Norton AntiVirus for Microsoft Exchange.