LiveUpdate terminates with return code 1878 when attempting to update virus definitions for Symantec Mail Security for Microsoft Exchange

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Article ID: 156016

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Updated On:

Products

Mail Security for Microsoft Exchange

Issue/Introduction

LiveUpdate fails to update virus definitions for Symantec Mail Security for Microsoft Exchange (SMSMSE) with the return value LU 1878: LiveUpdate was running when a logoff or system shutdown/restart was detected.

The following lines may be found in the Log.LiveUpdate file:

3/5/2012, 14:32:10 GMT -> While downloading updates, LuComServer detected the auto-shutdown flag; LuComServer will free all session resources and then terminate...
3/5/2012, 14:32:10 GMT -> EVENT - SESSION END SUCCESSFUL EVENT - The LiveUpdate session ran in Silent Mode. 
LiveUpdate found 1 updates available, of which 0 were installed and 1 failed to install. 
The LiveUpdate session exited with a return code of 1878, LiveUpdate was running when a logoff or system shutdown/restart was detected. 
LiveUpdate has automatically shut itself down.
3/5/2012, 14:32:10 GMT -> Failed to impersonate the COM client in the file download thread; err=1008
3/5/2012, 14:32:11 GMT ->

Failed to impersonate the COM client in the file download thread; err=1008

Conditions

The server experiencing the problem has very low bandwidth available, and LiveUpdate sessions require more than one hour to download a full definition set.

Cause

The LiveUpdate session took longer than the configured timeout value for SMSMSE LiveUpdate, by default 1 hour

Resolution

SMSMSE 6.5.x

To adjust the timeout value for LiveUpdate:

  1. Open the Registry editor (Start -> Run, Regedit)
  2. Navigate to HKEY_LOCAL_MACHINE\Software\Symantec\SMSMSE\6.5\Server. For 64 bit systems, navigate to HKEY_LOCAL_MACHINE\Software\Wow6432Node\Symantec\SMSMSE\6.5\Server
  3. In the right pane, right click the DWORD value "TimeoutForLiveUpdateProcess" and select Modify.... For the Base radio box select Decimal. The default value is 3600000 milliseconds (1 hour). 
  4. Enter a value that allows sufficient time for LiveUpdate to pull down a full definition package (in milliseconds, for example 7200000 is 2 hours).
  5. Restart the Symantec Mail Security for Microsoft Exchange service.

SMSMSE 7.0.x

To adjust the timeout value for LiveUpdate:

  1. Open the Registry editor (Start -> Run, Regedit)
  2. Navigate to HKEY_LOCAL_MACHINE\Software\Symantec\SMSMSE\7.0\Server. For 64 bit systems, navigate to HKEY_LOCAL_MACHINE\Software\Wow6432Node\Symantec\SMSMSE\7.0\Server
  3. In the right pane, right click the DWORD value "TimeoutForLiveUpdateProcess" and select Modify.... For the Base radio box select Decimal. The default value is 3600000 milliseconds (1 hour). 
  4. Enter a value that allows sufficient time for LiveUpdate to pull down a full definition package (in milliseconds, for example 7200000 is 2 hours).
  5. Restart the Symantec Mail Security for Microsoft Exchange service.