KNOWN ISSUE: Altiris agent does not run inventories if UI is opened during a boot delay

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Article ID: 155878

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Updated On:

Products

Management Platform (Formerly known as Notification Server)

Issue/Introduction

If the Altiris Agent Delay is used and the Agent UI window is opened during that delay, it disables any scheduled tasks, inventories, SWD until either a change is made to the policy config xml or services are restarted.

The policy in he AeXSWDPolicy.xml is being changed to Status removed="true"
and lastIsEnabled="false"

Cause

Steps to reproduce:

On a client machine set the registry setting to the time desired (5 minutes or
300 seconds)

Hkey_Local_Machine\Software\Altiris\Altiris Agent\Delay at System Boot
(secs) REG_DWORD 0x00000300 (768)

On the NS server have some tasks or Inventories or SWD ready to run at boot up.

Reboot the Client workstation. As that client comes up and is within that 5
minute delay. Open the Agent UI (either the Altiris Agent window or Altiris
Agent Details)

This breaks the Scheduled Tasks, Inventories, or SWD from running after the 5
minute delay expires. They will not run.

To get them to run again you must delete the Client policy and do an update
configuration. Once a new Client policy is installed then they will kick off
and run.

Resolution

One option would be to hide the agent icon to prevent this from happening. The user could also be educated to restart the services when exiting the Agent UI. Finally, this issue will resolve itself when it receives a change to its client configuration policy.
An etrack 2684039 was created for this issue.


Applies To

NS 6.0 Sp3 R13