The SMP console reports a task failure even though it is executed on the clients.

book

Article ID: 155821

calendar_today

Updated On:

Products

Management Platform (Formerly known as Notification Server)

Issue/Introduction

Client's which are registered with a Task Server are unable to send the results of Task Execution back to the SMP. The SMP console reports that the task has "not started" and will eventually fail with a timeout error despite the Task running successfully on the target client machine.

 

Cause

**Notification Server** The CTDataload.exe is pointing to the wrong location (C:\Program Files\Altiris\Altiris Agent\Client Task Server\CTDataload.exe). This service should be pointing to "C:\Program Files\Altiris\TaskManagement\CTDataload.exe"

**Site Server** The CTDataload.exe is pointing to the wrong location (C:\Program Files\Altiris\TaskManagement\CTDataload.exe). This service should be pointing to "C:\Program Files\Altiris\Altiris Agent\Client Task Server\CTDataload.exe"

Resolution

1) Stop the Altiris Object Host Service
2) Stop the Altiris Client Task Data Loader service
3) Open Registry Editor and Navigate to:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\ctdataloader
4) Edit the InstallPath REG_EXPAND_SZ value and change it to:
"C:\Program Files\Altiris\TaskManagement\CTDataload.exe"
5) Verify the service settings have changed by checking the service properties
6) Start the Altiris Client Task Dataloader service
7) Start the Altiris Object Host Service

Applies To

 SMP 7.1 SP1