Known Issue: Unexpected exception has occurred during the execution of the SQL for delta collection update for UNIX/Linux/Mac Computers Requiring Inventory Plug-in

book

Article ID: 155744

calendar_today

Updated On:

Products

Management Platform (Formerly known as Notification Server) Inventory Solution for Unix/Linux Inventory Solution

Issue/Introduction

Everytime delta resource membership update is run, it throws a warning stating:  Description: Unexpected exception has occurred during the execution of the SQL for delta collection update for  UNIX/Linux/Mac Computers Requiring Inventory Plug-in Upgrade (e50b60e7-a0a7-4e49-b338-b83896d6bb32~) . Full update is run instead. and Unexpected exception has occurred during the execution of the SQL for delta collection update for  UNIX/Linux/Mac Computers Requiring Inventory Pack for Servers Plug-in Upgrade.

Severity: 2
Process: AeXSvc (17180)
Thread: 323
Module: AeXSVC.exe
Source: Altiris.NS.StandardItems.Collection.NSDataSrcBasedResourceCollection.DeltaUpdateMembership
Description: Unexpected exception has occurred during the execution of the SQL for delta collection update for  UNIX/Linux/Mac Computers Requiring Inventory Pack for Servers Plug-in Upgrade (6434cd55-ba9f-4e9b-af3f-4edbfecaf624~) . Full update is run instead.

( Exception Details: System.Data.SqlClient.SqlException: Incorrect syntax near the keyword 'INSERT'.
Incorrect syntax near the keyword 'SET'.
Incorrect syntax near ')'.
 

Process: AeXSvc (17180)
Thread: 323
Module: AeXSVC.exe
Source: Altiris.NS.StandardItems.Collection.NSDataSrcBasedResourceCollection.DeltaUpdateMembership
Description: Unexpected exception has occurred during the execution of the SQL for delta collection update for  UNIX/Linux/Mac Computers Requiring Inventory Plug-in Upgrade (e50b60e7-a0a7-4e49-b338-b83896d6bb32~) . Full update is run instead.

( Exception Details: System.Data.SqlClient.SqlException: Incorrect syntax near the keyword 'INSERT'.
Incorrect syntax near the keyword 'SET'.
Incorrect syntax near ')'.

Cause

Unknown at this time.

Resolution

This will be resolved in a future release of the product.  This warning presents no functionality loss or data integrity issues.


Applies To

ITMS/CMS/SMS 7.x SP1 to SP2 Upgrade