SMTP Code: "450 4.4.1 (Internal) Connection Timed Out" when reverse DNS lookup is enabled

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Article ID: 155730

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Updated On:

Products

Messaging Gateway

Issue/Introduction

  • Symantec Messaging Gateway (SMG) cannot deliver mail for some external domains.
  • Emails stay in the delivery queue with the message "450 4.4.1 [internal] Connection Timed Out"
  • Testing with telnet from the SMG command line interface to the destination domain MX host connects successfully.

The Mail Log shows:

2018 Dec 29 16:39:35 CET (info) ecelerity: [26560] DNSDS-01074 Connection to mx4.domain.com would be 0/20 conns.
2018 Dec 29 16:39:35 CET (notice) ecelerity: [26560] SMTP-00352 (via connection.c:1055) failure request [38] #sms#00000000
2018 Dec 29 16:39:35 CET (notice) ecelerity: [26560] SMTP-00352 (via connection.c:1055) failure request [34] #sms#00000000

Cause

Messaging Gateway has been configured to perform a reverse DNS lookup as part of outbound mail processing, but the reverse lookup is failing.

Resolution

Disable the Reverse DNS Lookup for outbound mail.

  1. In the SMG Control Center, click the Administration tab.
  2. Navigate to Hosts > Configuration.
  3. Click on the scanner(s) having the problem to open their configuration.
  4. Click the SMTP tab, and then click Advanced Settings.
  5. Click the Outbound tab.
  6. Uncheck Enable reverse DNS lookup.
  7. Click Continue.
  8. Click Save.