Symantec Endpoint Protection Manager could not connect to the database.
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Symantec Endpoint Protection Manager could not connect to the database.

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Article ID: 155275

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Updated On:

Products

Endpoint Protection

Issue/Introduction

When the Administrator attempts to log on the Symantec Endpoint Protection Manager (SEPM), the following error is presented:
 

Error: Failed to connect to the server.

Symptoms:
 
1)      SEPM services stopped.
2)      ODBC connection credentials are not getting synchronized.
3)      Cannot run the Server Configuration Wizard due to the fact that the default port (8443) was already in use.
4)      Windows Application Event Logs display a “Java -1 error” for the failed logon attempt.
5)      In the “C:\Program Files\Symantec Endpoint Protection Manager\tomcat\logs\catalina.out” file, the following error message is seen (multiple times.):
Com.Sygate.SCM.Server.Util.SCMServerError: Failed to connect to database after tried 20 times. Please start the data

Failed to connect to the server.

Cause

When the SEPM was installed, the default port (8443) was already in use, and the service "Symantec Endpoint Protection Manager Webserver" was missing.

This can be confirmed by the following steps:
  1. Click Start > Run
  2. Type Services.msc > Enter
  3. Scroll down to the Symantec services and confirm the state of the service:
Symantec Endpoint Protection Manager Webserver
 

Resolution

Change the port to an unused port by following the Disaster Recovery procedure. In the event of a Disaster Recovery procedure to restore the SEPM Webserver service, choose a port number different from the default port 8443.

 

Follow Best Practices for Disaster Recovery with the Symantec Endpoint Protection Manager

Disaster recovery best practices for Endpoint Protection