Asset Management 7.1 Contract Expiring Automation Rule is unable to be modified to send email to the assigned user
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Asset Management 7.1 Contract Expiring Automation Rule is unable to be modified to send email to the assigned user

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Article ID: 155045

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Updated On:

Products

Asset Management Solution

Issue/Introduction

When trying to modify the Contract Expiring Automation Rule for Asset Management 7.1 using the instructions from the Altiris Asset Management Suite 7.1 User Guide, page 65, from the section "Configuring a contract expiration notification policy to send an email notification to the contract owner", this fails to send the specified user any email notification. When the SQL query is ran manually, the email address returns as NULL.

Cause

The user guide instructions are incorrect on how to enable this to work successfully.

Resolution

The following modified instructions enable the Contract Expiring Automation Rule to be correctly modified to send email to the assigned user.
 

  1. In a Symantec Management Console, click on the Manage button > Automation Policies.
  2. In the automation policies list, click on one of the following:
     
    * Contracts expiring in the next 30 days
    * Contracts expiring in the next 60 days
    * Contracts expiring in the next 90 days

    Note: A custom automation policy that uses this format can also be used instead of one of the three out of box automation policies.

  3. In the Details section, click on the "Edit query" link.
  4. On the Data Source window, under Base Query > Contract, click on vContract.
  5. Click on the Actions button > Add Joins.
  6. In the Joins window, in the first drop-down list, type "vUser". The list will take a moment and then find vUser. Click to select vUser from where it appears on the drop-down list. Note: If this is not picked directly off of the drop-down list, the remaining two drop-down lists will not populate correctly. If this has already happened, re-select vUser from the first drop-down list to reset the other two.
  7. In the bottom left drop-down list for "On", select "[vContract].[_AssignedUserGuid]", which should be the top-most choice.
  8. In the bottom right drop-down list, select "Guid".
  9. The Joins window appears like the following; if so, click on the OK button, if not, double check the values for steps 4 through 8.


     
  10. The Data Source window appears like the following; if so, click on the Fields tab, if not, double check the values for steps 4 through 9.


     
  11. Click on the Add button.
  12. In the drop-down list, type "vUser", then pick [vUser].[Email] from the list. Note: If this is not picked directly off of the drop-down list, the resulting data will not be seen correctly, similarly to how step 6 works.
  13. Click on the OK button. The [vUser].[Email] appears on the Fields list.
  14. Click on the OK button.
  15. Back on the main automation policy window, in the Actions section, click on the "Edit input parameter" link.
  16. Change the To drop-down list from [Custom] to Email.
  17. Click on the OK button.
  18. If the automation policy is turned off, click on the button to the left of the automation policy's name and choose Enable.
  19. Click on the "Save changes" button.