After enabling PPA logging, no trace enabled output appears
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After enabling PPA logging, no trace enabled output appears

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Article ID: 155022

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Updated On:

Products

IT Management Suite

Issue/Introduction

The following steps are required to enable PPA debug output into the Altiris Log Viewer or debug viewer utility:

1. Create the Registry Key: HKEY_LOCAL_MACHINE\SOFTWARE\Altiris\PluggableProtocols\Debug
  a. Create a string value: 'Dest' in Debug with 'AltirisLog' as data.
  b. Create DWORD: 'Level' with value '0' to enable all logs.
2. Add entry in Altiris Log Viewer’s watch folder.
  a. Enable show hidden folders option.
  b. Goto Altiris Log Viewer file > Watch Folder > Add: “C:\ProgramData\Symantec\Symantec Agent\Logs"

No PPA Debug output appears

Environment

ITMS 8.x

Cause

After enabling PPA logging (via steps details above) , it is required to manually restart the Altiris services for reflecting PPA related Logs in Altiris Log Viewer or Debug utility.

Resolution

Specifically, the Altiris Object Host service must be restarted as our Pluggable Protocols Architecture dll is loaded with this component. Restarting the PPA consumer specific application will also enable PPA log output after registry keys enabled. ( i.e. restarting the Monitor Solution’s RMS Agent)