Error: "554 5.7.1 Rejected message by MTA, RDNS record for connecting IP has no matching 'A' or 'MX' records"
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Error: "554 5.7.1 Rejected message by MTA, RDNS record for connecting IP has no matching 'A' or 'MX' records"

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Article ID: 154928

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Updated On:

Products

Messaging Gateway

Issue/Introduction

You have messages being rejected by the Symantec Messaging Gateway (SMG) with the following error: 554 5.7.1 Rejected message by MTA, RDNS record for connecting IP has no matching 'A' or 'MX' records.

554 5.7.1 Rejected message by MTA, RDNS record for connecting IP has no matching 'A' or 'MX' records.

Environment

Messaging Gateway

Cause

The SMG performs a reverse DNS lookup and cannot find an acceptable "A" record or "MX" record in the sender's DNS records.

Resolution

Recommended solution:

Contact the sender and have them update their DNS records with the relevant "A" or "MX" record.

Workaround:

Disable the "A/MX" check in SMG:

  1. Log into the Control Center as admin.
  2. Click Protocols > SMTP > Settings.
  3. Uncheck 'Reject connections where the reverse DNS record exists for the connecting IP address, but the 'A' or 'AAAA' record of the resulting domain does not match the connecting IP address.' under DNS Validation.
  4. Click Save.

Note: Some may consider this a security risk, as this may allow more senders to get through.