Rally: "Not authorized to update" error when creating a work item
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Rally: "Not authorized to update" error when creating a work item

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Article ID: 15489

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Updated On:

Products

Rally On-Premise

Issue/Introduction

When creating a new work item, an error is displayed such as the following example:

Error setting value for field [ Requirement ]: Not authorized to update: HierarchicalRequirement <ObjectID>" 

 

This can happen with any work item type that supports being parented such as a user story, feature, etc

Environment

Release:
Component: ACSAAS

Cause

This error may be triggered by a few scenarios

  • The parent work item is in a closed project
  • The parent work item is in a project which the user has no access to
  • The parent work item is in a project which the user has only viewer access to
  • This may also be caused by a backend problem with the user's access.

Resolution

The feature is already parented to another item which is either in a closed project or a project in which the user has no access.

-Based on the error there seems to a permissions issue with the parent or child.  

-When looking at the QDP page for the item the parent picker box shows 'no access';

-Further looking at the revision history shows that the feature is already parented to an item within a project for which the user has no access.

The remedy is to have a Workspace or subscription administrator remove the parent from the item, allowing the user to re-parent it appropriately. Creating a copy of the item will not eliminate the error.

If you've ensured that everything is in an open project and that the user has access to All work items involved (work item/portfolio item, current parent and new parent), it may be a backend problem with the user's access.  In this case, Support will need to be engaged to resolve.