search cancel

JMX metrics missing after deploying ACC Websphere Java Agent package in Websphere Liberty

book

Article ID: 15461

calendar_today

Updated On:

Products

CA Application Performance Management Agent (APM / Wily / Introscope) INTROSCOPE

Issue/Introduction

After deploying 10.5 ACC Websphere agent on WebSphere Liberty we noticed that JMX metrics are not being reported, all other metrics are reporting correctly.

 

Environment

Component: Agent 10.0, 10,1, 10.2, 10.3, 10.5.x

Cause

When using ACC Webphere Agent package you need to manually copy the <AGENT_HOME>/WebAppSupport.jar to the <Agent_Home>/core/ext

Resolution

1-Stop JVM

2.Download the ACC Websphere Agent package from ACC UI

3. Configure the agent with Websphere Liberty as per documentation

https://techdocs.broadcom.com/content/broadcom/techdocs/us/en/ca-enterprise-software/it-operations-management/application-performance-management/10-5/implementing-agents/java-agent/install-the-java-agent/configure-application-server-to-use-the-java-agent/websphere-liberty.html

4. IMPORTANT: Manually copy the <AGENT_HOME>/WebAppSupport.jar to the <Agent_Home>/core/ext

5.Start the JVM