Application pool keeps stopping and restarting constantly on the Symantec Management Platform
search cancel

Application pool keeps stopping and restarting constantly on the Symantec Management Platform

book

Article ID: 154509

calendar_today

Updated On:

Products

IT Management Suite Task Server

Issue/Introduction

Customer reported that IIS keeps crashing (we clarified to the customer that it was not crashing but rather stopping and restarting of the IIS service) constantly. The AppPool appears as stopped and the SMP Console displays a message HTTP ERROR 503 Service Unavailable.

 

After troubleshooting the issue we noticed the following in the System Event logs:

Event Type: Information
Event Source: Service Control Manager
Event Category: None
Event ID: 7035
Description:
The World Wide Web Publishing Service service was successfully sent a stop
control.


>>>>>>>>>>>>>>>>>>>>>>>
Event Type: Information
Event Source: Service Control Manager
Event Category: None
Event ID: 7036
Description:
The World Wide Web Publishing Service service entered the stopped state.


>>>>>>>>>>>>>>>>>>>>>>
Event Type: Information
Event Source: Service Control Manager
Event Category: None
Event ID: 7035
Description:
The World Wide Web Publishing Service service was successfully sent a start
control.


>>>>>>>>>>>>>>>>>>>>>>>>>
Event Type: Information
Event Source: Service Control Manager
Event Category: None
Event ID: 7036
Description:
The World Wide Web Publishing Service service entered the running state.
 

Before those messages for "The World Wide Web Publishing Service service entered the stopped state" we also noticed events like these ones:

Event Type: Information
Event Source: Service Control Manager
Event Category: None
Event ID: 7035
Description:
The Altiris Object Host Service service was successfully sent a start control.


>>>>>>>>>>>>>>>>>

Event Type: Information
Event Source: Service Control Manager
Event Category: None
Event ID: 7036
Description:
The Altiris Object Host Service service entered the running state.


>>>>>>>>>>>>>>>>>
Event Type: Information
Event Source: Service Control Manager
Event Category: None
Event ID: 7035
Description:
The Altiris Client Task Data Loader service was successfully sent a start
control.


>>>>>>>>>>>>>>>>>>>>
Event Type: Information
Event Source: Service Control Manager
Event Category: None
Event ID: 7036
Description:
The Altiris Client Task Data Loader service entered the running state.


>>>>>>>>>>>>>>>>>>>
Event Type: Information
Event Source: Service Control Manager
Event Category: None
Event ID: 7035
Description:
The Altiris Service Hoster service was successfully sent a start control.


>>>>>>>>>>>>>>>>>>>>>>>
Event Type: Information
Event Source: Service Control Manager
Event Category: None
Event ID: 7036
Description:
The Altiris Service Hoster service entered the running state.

Cause

Services were configured to restart according to the Task Service Settings policy.

Resolution

Trying to understand what was causing this, we found out the following setting on the SMP Console:
"Automatically restart services (Altiris Object Host Service, Client Task Data Loader, WWW Publishing" when configuration changes" under Settings>Notification Server>Site Server Settings, in the left tree under Site Management>Settings>Task Service>Settings>Task Service Settings.

In this case it was checked. By default it is not enabled. We removed that setting and this issue went away.

Also, make sure that the SMP server is not a member of more than 1 'Task Server Settings' configuration policy item.

 


Applies To

Symantec Management Platform 7.0 MR4

Symantec Management Platform 7.1 SP2

Task Server 7.0

Task Server 7.1