Directory Integration in Messaging Gateway cannot find a specific user
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Directory Integration in Messaging Gateway cannot find a specific user

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Article ID: 154421

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Updated On:

Products

Messaging Gateway

Issue/Introduction

  • Messaging Gateway (SMG) is configured to use Active Directory or LDAP server in Directory Integration server settings.
  • Cannot find a specific user when searching via test feature in SMG Directory Integration.
  • Other users are able to be found in testing.

"The recipient validation query was successful"

"The test address was not found in the directory (invalid recipient)."

Brightmaillog.log shows the following entry: "Address [email protected] is not unique. The following entries share the same email address: [result set too large, server returned no entries]"

 

Environment

Messaging Gateway 9.x or higher

Cause

The software is functioning within it's design.

The LDAP query is finding a search result, however, the result is returning more then one response. SMG cannot determine which response is correct, and fails the lookup.

Resolution

LDAP/AD server schema (forest) must contain entries that will give the SMG a unique response when authentication is requested.

The schema must be rewritten on the LDAP/AD side to prevent SMG errors from continuing.