Unable to enroll PGP Encryption Desktop clients using email enrollment over IMAP or POP3 with Exchange in Mailflow (Symantec Encryption Desktop)
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Unable to enroll PGP Encryption Desktop clients using email enrollment over IMAP or POP3 with Exchange in Mailflow (Symantec Encryption Desktop)

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Article ID: 153542

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Updated On:

Products

PGP Command Line PGP Encryption Suite PGP Key Management Server PGP Key Mgmt Client Access and CLI API PGP SDK Desktop Email Encryption Drive Encryption Encryption Management Server Endpoint Encryption File Share Encryption Gateway Email Encryption

Issue/Introduction

When using email enrollment for PGP Encryption Desktop clients, the mail client does not properly identify the enrollment email, the Next remains grayed out, and enrollment cannot continue (Symantec Encryption Desktop).

This issue occurs when using email enrollment over the IMAP or POP3 protocol with PGP Encryption Server (Symantec Encryption Management Server).

Cause

This issue is caused by Exchange removing the "X-PGP-Universal-Enrollment" header from the email before it is passed on to the client.

Resolution

This issue occurs when clients using IMAP or POP3 with a Microsoft Exchange 2007 server fail to properly process the PGP Encryption Server's  enrollment email message due to a missing X-header. When the PGP enrollment email is processed by the Exchange 2007 server, the X-header of the PGP Universal Server is not saved as the Exchange Server views the mail as an email from an anonymous source. When the mail client downloads the IMAP/POP3 message, the Exchange Server is unable to recreate the X-header for the enrollment message and enrollment cannot continue.

Workaround

To resolve this issue create an "X-PGP-Universal-Enrollment" value in the Exchange 2007 Server's named space.