Unable to enroll clients using email enrollment over IMAP or POP3 with Exchange in Mailflow
search cancel

Unable to enroll clients using email enrollment over IMAP or POP3 with Exchange in Mailflow

book

Article ID: 153542

calendar_today

Updated On:

Products

Symantec Products

Issue/Introduction

When using email enrollment for PGP Desktop clients, the mail client does not properly identify the enrollment email, the Next remains grayed out, and enrollment cannot continue.

This issue occurs when using email enrollment over the IMAP or POP3 protocol.

Cause

This issue is caused by Exchange removing the "X-PGP-Universal-Enrollment" header from the email before it is passed on to the client.

Resolution

This issue occurs when clients using IMAP or POP3 with a Microsoft Exchange 2007 server fail to properly process the PGP Universal Server's enrollment email message due to a missing X-header. When the PGP enrollment email is processed by the Exchange 2007 server, the X-header of the PGP Universal Server is not saved as the Exchange Server views the mail as an email from an anonymous source. When the mail client downloads the IMAP/POP3 message, the Exchange Server is unable to recreate the X-header for the enrollment message and enrollment cannnot continue.

Workaround

To resolve this issue create an "X-PGP-Universal-Enrollment" value in the Exchange 2007 Server's named space.