Unable to connect to the Remote SQL database during Installation of Symantec Endpoint Encryption (SEE) Manager
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Unable to connect to the Remote SQL database during Installation of Symantec Endpoint Encryption (SEE) Manager

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Article ID: 153127

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Updated On:

Products

Endpoint Encryption

Issue/Introduction

Unable to continue the Symantec Endpoint Encryption Manager installation, connection fails to the Remote SQL database.  Some examples of this are:

A network-related or instance-related error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: Named Pipes Provider, error: 40 - Could not open a connection to SQL Server)

An error has occurred while establishing a connection to the server.  When connecting to SQL Server 2005, this failure may be caused by the fact that under the default settings SQL Server does not allow remote connections. (provider: Named Pipes Provider, error: 40 - Could not open a connection to SQL Server) (.Net SqlClient Data Provider)

Cause

Issue with connecting the Symantec Endpoint Encryption Manager to the SQL Database

Resolution

Verify the settings to connect to the SQL Server are correct. Verify the Server name, FQDN, or IP address can be reached from the server. If using an Instance Name, configure this with the Server Name. Specify a valid port. Select Windows Authentication or SQL Authentication, and the credentials used.

If necessary, confirm the connectivity between the SEE Manager and SQL Database ODBC connection.

  • On the SQL Server:
    1. Open SQL Server Manager wizard
    2. Expand SQL Server Network Configuration
    3. Highlight Protocol {INSTANCE.EN_US}
    4. Double click on TCP/IP and click on IP Addresses
    5. Under IP1 verify “Enabled Yes” and “IP Address”. Note : IP Address of the SQL server
    6. Now under IP2 verify “Enabled Yes” and “IP Address” we have the loop back address which is 127.0.0.1
    7. Click on Apply and then Ok.
  • On the SEE Manager Server:
    1. Create a new text file and rename it as “test.udl”
    2. Right click on the “test.udl” and go to the properties
    3. In the connection tab, do the following:
      1. Under “Provider” select the “Microsoft OLE DB Provider for SQL Server” and click on “Next”.
      2. Verify in the “Security” tab, user has full permission.
      3. On the “Connection” tab, Under the “Select or enter a server name”  select the “servername\instancename”
      4. Select “Use Windows NT Integrated security” under “Enter information to log on to the server”
      5. Select the database under “Select the database on the server:”
    4. If the test connection completes successfully, the connection should be re-established with the SQL server.