User session hangs when a user logs off from Citrix server
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User session hangs when a user logs off from Citrix server

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Article ID: 153093

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Updated On: 03-03-2025

Products

IT Management Suite

Issue/Introduction

The user session hangs when a user is trying to log out from the Citrix server. When looking in the Window's Task Manager the AeXNSAgent.exe is running:

When they finish the session, our Sym Agent process still remains and doesn't close.

While using Process Explorer, we can see that those processes refer to:

AeXAgentUIHost.exe /host

Environment

ITMS 8.x

User: Windows 7 and later
Citrix server: Windows 2008 R2 and later

Cause

AeXNSAgent.exe is not stopping when a user is trying to log out.

Resolution

Note: Backup the registry prior to performing any editing.

Following the steps below to resolved this issue:

  1. On the problematic Citrix Server Open and go to the following location KEY_LOCAL_MACHINE\SOFTWARE\Altiris\Altiris Agent
  2. Set the "Run UI in main session only" to "1".

    This process hosts the system tray icon for those computers logged onto the NS via terminal services. In addition, you will see one instance of this process for each user logged on to the system.
    This registry key setting that can keep AexAgentUIHost.exe from loading for each user:

    HKLM\Software\Altiris\Altiris Agent\Run UI in main Session only

    Changing the value to 1 will keep the process from loading for every user.

  3. Restart the Symantec Management Agent upon completion.