Why do all of the scheduled tasks fail to start on one of our NS's?
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Why do all of the scheduled tasks fail to start on one of our NS's?

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Article ID: 153006

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Updated On:

Products

IT Management Suite

Issue/Introduction

All the NS scheduled Tasks in the scheduled tasks are failing to execute in one of the German servers. We are not able to edit the properties or change the schedules.

When you attempt to schedule a task using the Scheduled Task tool in Control Panel, you may receive either of the following error messages:

  • The new task has been created, but may not run because the account information could not be set. The specific error is:
    0x80090016: Keyset does not exist.
  • The new task has been created, but may not run because the account information could not be set. The specific error is:
    0x8009000f: Object already exists.

    Cause

    This behavior occurs because the Protected Storage service is not started or running on the Windows 2000 server.

    It can also be caused when the Crypto subsystem has become corrupted

    Resolution

    NOTE:: The following information was derived from Microsoft KB 246183. The KB Applies to Windows 2000, but it is known to work on Windows 2003

    WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

    1. Start the Protected Storage service by using either of the following methods: • Use the Compmgmt.msc snap-in. 

      Type the following command at a command prompt:
      net start "protected storage"
      Note 1: If the Crypto subsystem has become corrupted, you may have to back up the following subkey, then delete it, and then restart your computer.
      'HKEY_USERS\.Default\Software\Microsoft\Cryptography\Providers\Type 001 '
      Note 2: If this registry key does not exist, proceed to the next step.
    2. Test to determine if the issue is resolved. If the issue is resolved, skip the remaining steps. If the issue is not resolved, go to step 3.
    3. Start your computer in Safe mode, and then log on as administrator.
    4. Double-click My Computer, and then click Folder Options on the Tools menu.
    5. On the View tab, click to select Show hidden files and folders, and then click OK.
    6. Delete all of the files in the "C:\Documents and Settings\All Users\Application Data\Microsoft\Crypto\RSA\S-1-5-18" folder.
    7. Restart your computer, and then run the task.

    You may be able to carry out this procedure without having to boot into Safe Mode.


    Applies To

    Notification Server

    Task Scheduler