Agents does not execute any tasks - Error receiving the file
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Agents does not execute any tasks - Error receiving the file

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Article ID: 152984

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Updated On:

Products

Deployment Solution

Issue/Introduction

Clients are connected to the engine and active in the console. Some tasks when executed (even simple "dir" command line task) would complete successfully according to the console.

Yet when looking into client machine, we can see that on Agent status we have error message "Error receiving file: C:\Windows\Temp\rxscript.bat

Looking into %Temp% folder, we can see that file rxscript.bat file is 0 bytes size.

In the AClient/Dagent log file we have 0 bytes received error message or/and CIPCerror receiving the file

Cause

File Transfer port in the Engine has been set to 402 and conflicting with exiting communication port for client/engine.

Resolution

In DS Win32 console go to Options -> Global tab and deselect checkbox "Client/server file transfer port" to make this port dynamically detected or set it to other port than 401/402 to ensure that no conflict will occur.


Applies To

DS 6.9.xxx