Software Update Policy Wizard failed to complete creation process
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Software Update Policy Wizard failed to complete creation process

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Article ID: 152947

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Updated On:

Products

Patch Management Solution for Windows

Issue/Introduction

Recent HotFix/PointFix upgrades implemented and found the Software Update Policy Wizard failed with errors.

Failed to initialise SoftwareUpdateAdvertismentSetPolicy -> 'Method not found: 'Void Altiris.NS.StandardItems.SoftwareDelivery.AdvertisementItem.set_ClientDownloadsDisabled(Boolean)'.'

Software Update Distribution failed: CreateDistributionPolicy: Unable  to initialize policy 'MS17-005' for provided advertisement set. Please see log for details.CreateDistributionPolicy: Unable  to initialize policy 'MS17-005' for provided advertisement set. Please see log for details.   [System.Exception @ Altiris.PatchManagementCore]   at Altiris.PatchManagementCore.Resources.Helpers.StageAndDistributeHelper.CreateDistributionPolicy(SoftwareUpdateAdvertismentSet set, Guid guidTaskInstance, Guid newPolicyGuid, Boolean doAdvertInit, SoftwareUpdateAdvertismentSetPolicy& policy)   at Altiris.PatchManagementCore.Tasks.Server.SoftwareUpdateDistributionTask.Run(SoftwareUpdateAdvertismentSet sbAdvertSet)   at Altiris.PatchManagementCore.Tasks.Server.SoftwareUpdateDistributionTask.OnExecuteSingleton(IServerTaskExecutionInstance instance)

Exception logged from: 
   at Altiris.Diagnostics.Logging.EventLog.ReportException(Int32 severity, String strMessage, String category, Exception exception, String footer)
   at Altiris.PatchManagementCore.Tasks.Server.SoftwareUpdateDistributionTask.OnExecuteSingleton(IServerTaskExecutionInstance instance)
   at Altiris.PatchManagementCore.Tasks.Server.SerializingBaseSingletonServerTask`2.OnExecute(IServerTaskExecutionInstance i)
   at Altiris.TaskManagement.ServerTasks.BaseServerTask.Execute(ITaskExecutionEngine engine, IBaseTaskExecutionInstance instance, TaskInstanceRequest request)
   at Altiris.TaskManagement.Common.Execution.Engine.TaskEngineExecutionThread.ExecuteTaskHandler()
   at Altiris.TaskManagement.ServerTasks.ServerTaskExecutionThread.ExecuteTaskHandler()   at Altiris.TaskManagement.Common.Execution.Engine.TaskEngineExecutionThread.On Execute(Object eventComplete)   at System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)   at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)   at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)   at System.Threading.ThreadHelper.ThreadStart(Object obj)

**CEDUrlStart** :http://entced.symantec.com/entt?
product=SMP&version=7.6.1383.0&language=en&module=OkLuIKq+p3MSbdr/EToGsgoO/QnrF/1qPL4xztp6/ILqFy2LnQJ86Kt4D7F46FFBg7li/F/yJfTv1ldLqtrWfw==&error=-843971519&build=**CEDUrlEnd**

Environment

Patch Management 7.6.x and 8.0.x

Cause

The upgraded HotFix / PointFix failed without errors during process causing data corruption in Patch Management base processes: Confirmed the typical message about “Install successful” was missing from the end of the log; however, the following was found in the logs: Access to the path 'DRIVE:\Program Files\Altiris\DirectoryServices\Web\ColumnMappingsSelectDlg.aspx' is denied. Additionally, found the executable for the PF was set to ReadOnly.

Additionally, hung tasks could impact this issue regarding the inability to download the Import Patch Data for Windows (PMImport) as found in the SSE Reports > Server > Task > Currently Running Known Tasks report (HOWTO52986).

 

Resolution

Worked through the following:

  1. Performed process to truncate hung Task History as detailed on TECH144662 / TECH209754:
    • Stopped specific Services running on SMP Server
      • Altiris Support Service
      • Altiris Service
      • Altiris Object Host Service
      • Altiris Client Task Data Loader Service
    • Truncated the listed Task History tables in SQL Server Management Studio on the Symantec_CMDB database:
      • Truncate table TaskInstanceSummaries
      • Truncate table TaskInstanceResults
      • Truncate table TaskInstances
      • Truncate table TaskinstanceParents
      • Truncate table TaskInstancesStarted 
      • Truncate table TaskInstanceStatus 
      • Truncate table TaskOutputPropertyValue
      • Truncate table TaskInstanceEvents
      • Truncate table TaskInstanceExecutionInfo
      • Truncate table TaskInstanceJobNodes 
      • Truncate table TaskInstanceresultSummaries
      • Truncate table ServerTaskInstancerequests
      • Truncate table ClientTaskInstancerequests
    • Ran orphan clean-up scripts
      • Exec tmCleanupSummaryOrphans
      • Exec tmCleanupTaskOrphans
        • Note: This cleanup task was removed in ITMS 8.1.x
    • Started specific Services for Altiris on SMP Server from list above
      • Note: Some task tables may no longer be present in the database as later versions of Task were streamlined for performance, and several tables were added in recent ITMS 8.1 RU2 versions:
        • Truncate table TaskInstancesCompleted
        • Truncate table TaskInstancesIncomplete
  2. Performed full repair of Patch Management Solution as detailed on HOWTO47868.
    • Logged onto SMP Server with Application Identity credentials
    • Ran repair through SIM and reconfiguration CMDs
       
  3. Performed reinstall of the PointFix outlined on INFO4200.
    • Confirmed logged in with Application Identity
    • Checked permissions on the file: ColumnMappingsSelectDlg.aspx; confirmed in order
    • Removed the ReadOnly attribute from the Pointfix executable 
    • Re-ran PF; confirmed completed without errors and process to build Software Update Policies was then in order

Advisory: The errors failing to be present to display failed on PointFix implementation from INFO4200 is currently being reviewed by Symantec Corp. 

  • To remove this PointFix:
    • Log onto the SMP Server with Application Identity (Symantec Service User) 
    • Run the PFInstaller.exe found in the package downloaded from INFO4200 
    • Configure the PMImport > Software & Vendor list to exclude the click-to-run O365 Software
    • Run the PMImport with the setting enabled: Delete previously downloaded data for vendors, software, and languages that are now excluded​